Download Práctica 1 - Instalacion del JDK y TextPad

Survey
yes no Was this document useful for you?
   Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Document related concepts
no text concepts found
Transcript
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
1
INSTITUTO TECNOLOGICO DE MINATITLÁN
FUNDAMENTOS DE PROGRAMACION
ING. JOSE ANGEL TOLEDO ALVAREZ
PRACTICA 1
INSTALACION Y RECONOCIMIENTO DE JDK Y
TEXTPAD
MILDRED MAGDALENA VARGAS HERNANDEZ
SEMESTRE: 1 GRUPO: 311
INGENIERIA EN SISTEMAS COMPUTACIONALES.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
2
OBJETIVO
El objetivo de esta práctica es que el usuario o programador, aprenda a instalar
programas de manera fácil y sencilla, para poder iniciar en la programación. En esta
ocasión, los programas instalados fueron, jdk, textpad, y jcreator.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
3
MARCO TEORICO
¿Qué es java?
Java es un lenguaje de programación orientado a objetos desarrollado por
Sun Microsystems a principios de los años 1990. Las aplicaciones Java están
típicamente compiladas en un bytecode, aunque la compilación en código máquina
nativo también es posible. En el tiempo de ejecución, el bytecode es normalmente
interpretado o compilado a código nativo para la ejecución, aunque la ejecución
directa por hardware del bytecode por un procesador Java también es posible.
El lenguaje en sí mismo toma mucha de su sintaxis de C y C++, pero tiene un
modelo de objetos más simple y elimina herramientas de bajo nivel como punteros.
JavaScript, un lenguaje interpretado, comparte un nombre similar y una sintaxis
similar, pero no está directamente relacionado con Java.
Sun Microsystems proporciona una implementación GNU General Public
License de un compilador Java y una máquina virtual Java, conforme a las
especificaciones del Java Community Process, aunque la biblioteca de clases que se
requiere para ejecutar los programas Java no es software libre.
Entre noviembre de 2006 y mayo de 2007, Sun Microsystems liberó la mayor
parte de sus tecnologías Java bajo la licencia GNU GPL, de acuerdo con las
especificaciones del Java Community Process, de tal forma que prácticamente todo el
Java de Sun es ahora software libre.
Java ha experimentado numerosos cambios desde la versión primigenia, JDK
1.0, así como un enorme incremento en el número de clases y paquetes que componen
la librería estándar. Desde J2SE 1.4, la evolución del lenguaje ha sido regulada por el
JCP (Java Community Process), que usa Java Specification Requests (JSRs) para
proponer y especificar cambios en la plataforma Java. El lenguaje en sí mismo está
especificado en la Java Language Specification (JLS), o Especificación del Lenguaje
Java.
Los cambios en los JLS son gestionados en JSR 901.

JDK 1.0 (23 de enero de 1996) — Primer lanzamiento.

JDK 1.1 (19 de febrero de 1997) — una reestructuración intensiva del modelo
de eventos AWT (Abstract Windowing Toolkit) , clases internas (inner classes)
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
o

4
J2SE 1.2 (8 de diciembre de 1998) — Esta y las siguientes versiones
fueron recogidas bajo la denominación Java 2 y el nombre "J2SE" (Java
2 Platform, Standard Edition), reemplazó a JDK para distinguir la
plataforma base de J2EE (Java 2 Platform, Enterprise Edition) y J2ME
(Java 2 Platform, Micro Edition).
J2SE 1.3 (8 de mayo de 2000) — Nombre clave Kestrel.
o

PRACTICA 1
J2SE 1.4 (6 de febrero de 2002) — Nombre Clave Merlin. Este fue el
primer lanzamiento de la plataforma Java desarrollado bajo el Proceso
de la Comunidad Java como JSR 59
J2SE 5.0 (30 de septiembre de 2004) — Nombre clave: Tiger. (Originalmente
numerado 1.5, esta notación aún es usada internamente.[4]) Desarrollado bajo
JSR 176, Tiger añadió un número significativo de nuevas características.
JDK.
El Java Development Kit, JDK por sus siglas en ingles, es un compilador y
conjunto de herramientas de desarrollo para la creación de programas independientes y
applets java.
Compilación es el proceso por el cual se traducen programas en código fuente a
programas en código objeto. El programa que realiza esta traducción se llama
compilador. El archivo de código objeto que se obtiene con la compilación está
representado normalmente en código de máquina, aunque también puede ser un
código intermedio binario multiplataforma (bytecode).
Para conseguir el programa ejecutable final a partir de todos los archivos de
código objeto se debe utilizar un programa llamado montador y un enlazador (linker).
Este proceso de montaje tiene como resultado un archivo ejecutable que contiene el
programa en código máquina listo para ser ejecutado con la ayuda del sistema
operativo. El proceso de enlazamiento arregla las referencias a subrutinas externas.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
5
¿Qué es el textpad?
TextPad es un popular editor de texto para la famila de sistemas operativos
Microsoft Windows.
La primera versión del programa apareció en 1992 y desde entonces Helios
Software Solutions lo ha seguido desarrollando, de hecho, actualmente este software
está en su cuarta major version (4.7.3).
Entre las características principales se incluyen:
Capacidad de indentar (distinguir separando mediante espacios) bloques.
Indentación automática de código.
Búsquedas y reemplazos basados en expresiones regulares.
Grabación de macros para facilitar la transformación de textos y
procesamiento.
Las características de las macros también permiten búsquedas y reemplazos usando
expresiones regulares.
Resaltado de sintaxis para diversos lenguajes (personalizable).
Capacidad de llamar a programas externos, tales como compiladores.
Soporte para archivos grandes.
Soporte para la edición de múltiples archivos.
Modo de selección de bloque.
Sincronización del scroll en múltiples ficheros.
Existe otro programa llamado WildEdit que es una herramienta interactiva para
usuarios avanzados que permite hacer cambios a múltiples archivos dentro de la
jerarquía de dicheros.
Aunque la versión de prueba de TextPad y de WildEdit disponibles para evolución es
completamente funcional, ninguno de los dos programas es shareware.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
6
DESARROLLO
INSTALACION DE JAVA (JDK)
Esta ventana es la ventana de instalación de java, para poder instalar java, debe darse
clic en el botón next o siguiente.
Esta ventana indica la recopilación de información del software instalado, debe dejarse
cargar completamente para poder pasar al siguiente paso.
En esta ventana deben aceptarse los términos y condiciones de la licencia del software
para poder instalar.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
7
Aquí se eligen los componentes que se desean instalar del jdk, se da clic en siguiente
(next).
En esta ventana se muestra el estado de la instalación del programa.
Si la computadora, ya tiene el programa instalado, aparecerá esta ventan, dónde se
debe aceptar para reinstalar jdk.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
8
Se realizan nuevamente los pasos 2 y 4.
En esta ventana se instalan los componentes de java y se marca el status de instalación.
Esta es la ventana final de instalación jdk, se da clic en finalizar (finish) y esta listo para
usarlo.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
9
INSTALACION DE TEXTPAD.
Este es un programa que sirve como una aplicación para jdk, más bien sirve para
compilar y ejecutar los programas.
En esta ventana se muestra la preparación para instalar el programa y se comprueba la
version del sistema operativo que tiene la PC.
Esta es una pantalla de bienvenida al software, solo hay que dar clic en siguiente.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
10
El asistente se prepara para instalar, pregunta si la configuración es correcta, se da clic
en instalar.
En esta ventana se ve el estado de instalación, se deja pasar solamente. ( si se da clic en
cancelar, se cancelaría toda la instalación.
Esta es la pantalla final, indica que ha sido instalado correctamente. Se da clic en
finalizar.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
11
EJECUCIÓN DEL PROGRAMA “HOLA MUNDO”
Desarrollo del programa “Hola Mundo”
public class Hola{
public static void main(String [] args){
System.out.println("Hola Mundo");
}
}
Compilación de “Hola Mundo”
1.- Entramos al programa Textpad.
2.- Abrimos nuestro archivo donde se encuentra nuestra aplicación “Hola Mundo”,
este se debe de llamar igual a la palabra escrita después de class, en este caso “Hola” y
se debe encontrar en la carpeta BIN del JDK.
3.- Vamos al menú Herramientas y elegir la opción de Compilar Java (Ctrl. + 1).
Ejecución de “Hello World”
1.- Después de haber compilado nuestro programa correctamente elegir el Menú
Herramientas.
2.- Elegir la opción de Ejecutar aplicación JAVA (Ctrl. + 2).
3.- Se abrirá una ventana parecida al símbolo de sistema dónde estará nuestro
programa ya funcionando, como se muestra en la siguiente imagen:
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
12
Observaciones.
Para poder instalar los programas no hubo problema alguno, pues la
computadora funcionaba bien, y ya tenia los programas descargados, el problema fue
al ejecutar el programa, pues no quiso compilar de manera normal, pedía una clave, Al
final rescribí el programa en jcreator y desde ahí pude ejecutar.
Conclusiones
No se me hizo muy agradable la ejecución de programas en textpad, se me
facilito aun más utilizar jcreator, por que tiene más opciones.
En lo personal nunca había utilizado java, pero creo que es un lenguaje de
programación muy completo y fácil de usar, pues es orientado a objetos, creo que para
cualquier programador le agradaría utilizarlo en lugar de lenguajes como C++ o
pascal.
Bibliografía
http://www.proclave.com/esp/cursos/glosario.htm.
http://es.wikipedia.org/wiki/Java
http://es.wikipedia.org/wiki/TextPad
http://es.wikipedia.org/wiki/Fichero
http://www.monografias.com/trabajos/gloscompu/gloscompu.shtml
http://72.14.253.104/search?q=cache:ii0XAhHGnR8J:mx.geocities.com/emma_max
im111/PRACTICA_1.doc+fundamentos+textpad&hl=es&ct=clnk&cd=12&gl=mx
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
13
Glosario:
Aplicación: Un programa de ordenador que se compra ya realizado y listo para usar.
Las hay de muy diversos tipos, según para qué propósito se hayan diseñado:
procesadores de texto, bases de datos, programas de contabilidad, de facturación, etc.
Archivos:
Se suele usar como sinónimo de fichero. En el mundo de los
compresores, es frecuente hacer una diferenciación, diciendo que varios ficheros
originales se comprimen y se empaquetan en un archivo comprimido.
Clase:
son declaraciones o abstracciones de objetos, lo que significa, que
una clase es la definición de un objeto. Cuando se programa un objeto y se definen sus
características y funcionalidades, realmente se programa una clase
Código fuente:
Programa en su forma original, tal y como fue escrito por el
programador, el código fuente no es ejecutable directamente por el computador, debe
convertirse en lenguaje de maquina mediante compiladores, ensambladores o
interpretes.
Compilador:
Programa de computadora que produce un programa en lenguaje
de maquina, de un programa fuente que generalmente esta escrito por el programador
en un lenguaje de alto nivel.
Ejecutar:
En informática, la palabra "ejecutar" (en inglés "run", que algunos
autores traducen literalmente por "correr") equivale a poner un programa en
funcionamiento
Fichero:
Un archivo o fichero informático es una entidad lógica compuesta
por una secuencia finita de bytes, almacenada en un sistema de archivos ubicada en la
memoria secundaria de un ordenador. Los archivos son agrupados en directorios
dentro del sistema de archivos y son identificados por un nombre de archivo. El
nombre forma la identificación única en relación a los otros archivos en el mismo
directorio.
Indentar:
distinguir separando mediante espacios
Java:
Lenguaje de programación orientado a objetos, basado en C++,
cada día más extendido, especialmente a través de Internet.
Licencia:
Derecho que adquiere una empresa para explotar un invento, una
marca o una tecnología determinada.
Macros:
Conjunto de instrucciones que ejecutan una función
automáticamente dentro de un programa. El grabador de macros graba primero todas
las instrucciones que recibe.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
14
Plataforma:
es precisamente el basamento, ya sea de hardware o software,
sobre el cual un programa puede ejecutarse. Ejemplos típicos incluyen: arquitectura de
hardware, sistema operativo, lenguajes de programación y sus librerías de tiempo de
ejecución.
Sincronización:
Proceso mediante el cual se transmite datos del PDA al
ordenador PC o Mac, actualizando la información existente. La sincronización se
realiza en la mayoría de los casos con un "cradle", vía serie o USB, aunque también
existen cables de sincronización
Software libre:
Software libre es el software que, una vez obtenido, puede ser
usado, copiado, estudiado, modificado y redistribuido libremente. El software libre
suele estar disponible gratuitamente en Internet, o a precio del coste de la distribución
a través de otros medios; sin embargo no es obligatorio que sea así y, aunque conserve
su carácter de libre, puede ser vendido comercialmente.
Soporte:
Objeto físico susceptible de ser tratado en un sistema de
información y sobre el cual se pueden gravar o recuperar datos
Tecnología:
Aplicación del conocimiento científico u organizado a las tareas
prácticas por medio de sistemas ordenados que incluyen las personas, las
organizaciones, los organismos vivientes y las máquinas.
Textpad:
es un popular editor de texto para la familia de sistemas
operativos Microsoft Windows.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
15
GLOSARIO DE COMANDOS.
MENÚ ARCHIVO
Comando Nuevo
Utilice este comando para crear un documento sin nombre.
Para abrir un documento nuevo y asignarle un nombre al mismo tiempo, utilice el
comando Abrir.
Comando Abrir
Utilice este comando para abrir documentos existentes.
Seleccione el archivo (o archivos) en el cuadro de diálogo Abrir archivo que
aparecerá.
Comando Cerrar
Utilice este comando para cerrar todas las vistas que contengan el documento
activo.
Antes de cerrar, se le solicitará que guarde los cambios realizados en el
documento. Si cierra un documento sin guardarlo, perderá todos los cambios
realizados desde la última vez que se guardó. Antes de cerrar un documento sin
título, aparecerá el cuadro de diálogo Guardar como, como sugerencia para que
asigne un nombre al documento y lo guarde.
Comando Cerrar todos
Utilice este comando para cerrar todos los documentos. Si ha modificado
alguno, se le solicitará que lo guarde antes de cerrar su ventana.
Comando Guardar como
Utilice este comando para guardar el documento activo con otro nombre.
Aparecerá el cuadro de diálogo Guardar como, que permite introducir el nuevo
nombre.
Comando Guardar todos
Utilice este comando para guardar todos los documentos modificados.
La primera vez que guarde un documento sin nombre, aparecerá el cuadro de
diálogo Guardar como, para que pueda asignarle un nombre.
Comando Volver a abrir
Utilice este comando para volver a abrir el documento activo con el estado que
tenía la última vez que se guardó. Antes de volver a cargar el archivo, se le
preguntará si está de acuerdo en perder algunos cambios.
Comando Cambiar nombre
Utilice este comando para cambiar el nombre del archivo del que procede el
documento activo. También puede utilizarse para mover el archivo a otra carpeta.
Comando Abrir área de trabajo (menú Archivo)
Utilice este comando para abrir áreas de trabajo guardados previamente.
Comando Guardar área de trabajo como
Utilice este comando para guardar el área de trabajo actual en un archivo
distinto o para crear otra área de trabajo.
Comando Administrar archivos
Utilice este comando para abrir, copiar, cambiar el nombre o actualizar las
marcas de hora de archivos.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
16
Comando Imprimir
Utilice este comando para imprimir el documento activo.
Este comando abre el cuadro de diálogo Imprimir, que permite especificar el
intervalo de páginas que se va a imprimir, el número de copias, la impresora de
destino y otras opciones de configuración de impresión.
Comando Vista previa
Utilice este comando para ver el aspecto que tendría impreso el documento
activo.
Al elegir este comando, la ventana principal se convierte en una ventana de
vista previa en la que aparecen una o dos páginas en formato impreso. La barra de
herramientas de vista previa incluye opciones para ver una o dos páginas a la vez,
desplazarse por el documento, acercar y alejar las páginas e iniciar el trabajo de
impresión.
Comando Configurar página
Utilice este comando para configurar los márgenes, el encabezado y el pie de
página de los documentos impresos que pertenezcan a la clase del documento
activo. Sin utiliza este comando sin que haya documentos abiertos, los cambios se
aplicarán a todas las clases de documentos.
Comando Enviar (menú Archivo)
Utilice este comando para enviar el documento activo a otra persona a través
del correo electrónico. Para activar este comando debe tener instalado un sistema
de correo electrónico compatible con MAPI.
MENU EDITAR
Comando Cortar
Utilice este comando para quitar el texto seleccionado del documento y
colocarlo en el portapapeles. No está disponible si no hay texto seleccionado
Al cortar el texto y copiarlo en el portapapeles, se reemplaza el contenido
almacenado previamente.
Comando Copiar
Utilice este comando para copiar el texto seleccionado del documento en el
portapapeles. No está disponible si no hay texto seleccionado
Al copiar el texto en el portapapeles se reemplaza el contenido almacenado
previamente.
Comando Pegar
Utilice este comando para insertar el contenido del portapapeles en la posición
del cursor, o para reemplazar la selección actual. No está disponible si no hay texto
en el portapapeles.
Comando Cortar anexión de selección
Utilice este comando para quitar el texto seleccionado del documento y
anexarlo al texto existente en el portapapeles. No está disponible si no hay texto
seleccionado
Comando Cortar línea
Utilice este comando para quitar del documento la línea que contiene el cursor
y colocarla en el portapapeles. No está disponible si la selección se extiende más
allá de un límite de línea.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
17
Comando Cortar anexión de línea
Utilice este comando para quitar del documento la línea que contiene el cursor
y anexarla al texto existente en el portapapeles. No está disponible si la selección se
extiende más allá de un límite de línea.
Comando Cortar palabra
Utilice este comando para quitar del documento la palabra que contiene el
cursor y colocarla en el portapapeles. No está disponible si hay texto seleccionado.
Comando Cortar anexión de palabra
Utilice este comando para quitar del documento la palabra que contiene el
cursor y anexarla al texto existente en el portapapeles. No está disponible si hay
texto seleccionado.
Comando Cortar líneas con marcadores
Utilice este comando para eliminar todas las líneas que tengan marcadores y
colocarlas en el portapapeles.
Comando Copiar línea
Utilice este comando para copiar en el portapapeles la línea que contiene el
cursor. No está disponible si la selección se extiende más allá de un límite de línea.
Comando Copiar anexión de línea
Utilice este comando para anexar la línea que contiene el cursor al texto que
exista en el portapapeles. No está disponible si la selección se extiende más allá de
un límite de línea.
Comando Copiar palabra
Utilice este comando para copiar en el portapapeles la palabra que contiene el
cursor. No está disponible si hay texto seleccionado.
Comando Copiar anexión de palabra
Utilice este comando para anexar la palabra que contiene el cursor al texto que
exista en el portapapeles. No está disponible si hay texto seleccionado.
Comando Copiar líneas con marcadores
Utilice este comando para copiar en el portapapeles todas las líneas que tengan
marcadores.
Comando Copiar nombre de archivo
Utilice este comando para copiar en el portapapeles el nombre de archivo del
documento activo.
Comando Copiar todos los nombres de archivo
Utilice este comando para copiar los nombres de archivo de todos los
documentos activos en el portapapeles.
Comando Pegar como bloque
Utilice este comando para insertar, en modo de bloque, el contenido del
portapapeles en la posición del cursor, o para reemplazar la selección actual. Este
formato anula el formato actual del portapapeles. No está disponible si no hay
texto en el portapapeles o si el ajuste de línea está activado.
Comando Pegar como líneas
Utilice este comando para insertar, en modo de línea (normal), el contenido del
portapapeles en la posición del cursor, o para reemplazar la selección actual. Este
formato anula el formato actual del portapapeles. No está disponible si no hay
texto en el portapapeles.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
18
Comando Insertar estadísticas
Utilice este comando para insertar el recuento de palabras, líneas y caracteres en
el documento.
Comando Insertar nombre de archivo
Utilice este comando para insertar el nombre completo del archivo del
documento activo en la posición del cursor, o para reemplazar la selección actual.
Está desactivado para documentos que nunca se han guardado en un archivo.
Comando Insertar archivos
Utilice este comando para insertar el contenido de uno o más archivos en la
posición del cursor, o para reemplazar la selección actual. Aparecerá el cuadro de
diálogo Abrir archivo, donde podrá seleccionar los archivos que desee insertar.
Comando Insertar hora
Utilice este comando para insertar la hora actual en la posición del cursor. El
formato que se utiliza es el especificado en el subprograma Configuración regional
del Panel de control.
Comando Insertar fecha corta
Utilice este comando para insertar la fecha actual en la posición del cursor. El
formato que se utiliza es el especificado para fechas cortas en el subprograma
Configuración regional del Panel de control.
Comando Insertar fecha ampliada
Utilice este comando para insertar la fecha actual en la posición del cursor. El
formato que se utiliza es el especificado para fechas ampliadas en el subprograma.
Configuración regional del Panel de control.
Comando Eliminar líneas con marcadores
Utilice este comando para eliminar todas las líneas que tengan marcadores
Comando Eliminar línea
Utilice este comando para eliminar del documento la línea que contiene el
cursor. No está disponible si la selección se extiende más allá de un límite de línea.
Comando Eliminar palabra
Utilice este comando para eliminar del documento la palabra que contiene el
cursor. No está disponible si hay texto seleccionado.
Comando Invertir
Utilice este comando para convertir la selección de mayúsculas a minúsculas y
viceversa.
Si no hay texto seleccionado, se convierte el carácter situado después del cursor
y éste se desplaza una posición hacia la derecha.
Comando Mayúscula
Utilice este comando para convertir la selección de minúsculas a mayúsculas.
Si no hay texto seleccionado, se convierte el carácter situado después del cursor y
éste se desplaza una posición hacia la derecha.
Comando Minúscula
Utilice este comando para convertir la selección de mayúsculas a minúsculas.
Si no hay texto seleccionado, se convierte el carácter situado después del cursor y
éste se desplaza una posición hacia la derecha.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
19
Comando Inicio de frase
Utilice este comando para poner en mayúsculas el primer carácter de cada frase
de la selección actual y el resto en minúsculas.
Este comando no está disponible si no hay texto seleccionado.
Comando Poner en mayúscula
Utilice este comando para poner en mayúsculas el primer carácter de cada
palabra de la selección actual y el resto en minúsculas.
Comando Alineación izquierda
Utilice este comando para alinear las líneas seleccionadas actualmente en el
margen izquierdo. No puede utilizarse con las fuentes de espaciado proporcional.
Comando Alineación centrada
Utilice este comando para centrar las líneas seleccionadas actualmente entre los
márgenes de ajuste de palabra izquierdo y derecho. No puede utilizarse con las
fuentes de espaciado proporcional.
Comando Alineación derecha
Utilice este comando para alinear las líneas seleccionadas actualmente en el
margen derecho. No puede utilizarse con las fuentes de espaciado proporcional.
Comando Alineación justificada
Utilice este comando para separar las palabras uniformemente entre ambos
márgenes. No puede utilizarse con las fuentes de espaciado proporcional.
Comando Aumentar sangrado
Utilice este comando para aumentar el sangrado de las líneas seleccionadas.
Tenga en cuenta que si hay más de una línea seleccionada, la tecla Tabulador tiene
el mismo efecto.
Comando Reducir sangrado
Utilice este comando para reducir el sangrado de las líneas seleccionadas.
Tenga en cuenta que si hay más de una línea seleccionada, Shift+Tabulador
tiene el mismo efecto.
Comando Juntar líneas
Utilice este comando para juntar las líneas seleccionadas. Todas las líneas se
anexan a la primera, separadas entre sí por un espacio.
Comando Nuevo formato
Utilice este comando para adaptar la longitud de las líneas seleccionadas al
margen determinado para el ajuste de línea. Las palabras se cambian de línea
cuando es necesario. Las líneas vacías se conservan como
Comando Seleccionar todo
Utilice este comando para seleccionar el documento completo.
Comando Marcar no modificado
Utilice este comando para vaciar las memorias de Deshacer y Rehacer. Cuando
estas memorias están vacías, el comando Guardar está desactivado y no se le
solicita que guarde el documento al cerrarlo. El efecto es como si nunca se hubiera
modificado el documento.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
20
MENU BUSCAR
Comando Buscar
Utilice este comando para especificar una cadena de búsqueda y los criterios de
la búsqueda, por ejemplo, si deben coincidir las mayúsculas y minúsculas. Abre el
cuadro de diálogo Buscar, que puede mantenerse permanentemente en la pantalla.
Comando Buscar en archivos
Utilice este comando para especificar una cadena de búsqueda, los criterios de
la búsqueda, por ejemplo si deben coincidir las mayúsculas y minúsculas, y la lista
de archivos que desee buscar. Aparecerá el cuadro de diálogo Buscar en archivos,
que puede mantenerse permanentemente en la pantalla.
Comando Reemplazar
Utilice este comando para especificar cadenas de búsqueda y reemplazo y los
criterios de la búsqueda, por ejemplo, si deben coincidir las mayúsculas y
minúsculas. Abre el cuadro de diálogo Reemplazar, que puede mantenerse
permanentemente en la pantalla.
Comando Ir a línea
En los archivos de texto, este comando desplaza el cursor hasta el principio de
una línea, página, columna, desplazamiento de bytes o marcador especificado.
Aparecerá el cuadro de diálogo Ir a, en el que podrá escribir el número. Los
números con signo (+ ó -) se interpretarán como desplazamientos relativos a la
posición del cursor.
En los archivos binarios, este comando desplaza el cursor hasta un
desplazamiento especificado del archivo. Aparecerá el cuadro de diálogo Ir a
dirección, en el que podrá escribir la dirección en caracteres hexadecimales.
Comando Conmutar marcador
Utilice este comando para establecer o borrar un marcador en la línea actual.
Comando Marcador siguiente
Utilice este comando para ir a la siguiente línea que contenga un marcador.
Comando Marcador anterior
Utilice este comando para ir a la anterior línea que contenga un marcador.
Comando Invertir todos los marcadores
Utilice este comando para suprimir los marcadores de las líneas que los tengan
y colocar marcadores en las líneas que no tenían.
Comando Borrar todos los marcadores
Utilice este comando para suprimir todos los marcadores del documento activo.
Comando Ir a cierre de paréntesis
Utilice este comando para ir hasta el paréntesis de cierre correspondiente al
paréntesis de apertura situado tras el cursor (o viceversa).
MENU VER:
Comando Barra de estado
Muestra u oculta la barra de estado. Este parámetro está también disponible en
la página Ver del cuadro de diálogo Preferencias.
Comando Biblioteca de recortes
Muestra u oculta la biblioteca de recortes.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
21
Comando Selector de documentos
Muestra u oculta el selector de documentos. El selector de documentos es una
lista de los documentos abiertos que puede utilizar para pasar de uno a otro.
Comando Barra de herramientas Buscar
Muestra u oculta la barra de herramientas que contiene los comandos del menú
Buscar.
Comando Barra de herramientas Macros
Muestra u oculta la barra de herramientas que contiene los comandos del menú
Macros.
Comando Barra de herramientas Herramientas
Muestra u oculta la barra de herramientas que contiene los comandos del menú
Herramientas.
Comando Barra de herramientas Ventana
Muestra u oculta la barra de herramientas que contiene los comandos del menú
Ventana.
Comando Personalizar barras de herramientas
Muestra un cuadro de diálogo para personalizar los botones de las barras de
herramientas.
Comando Barra de desplazamiento vertical
Muestra u oculta la barra de desplazamiento vertical en la ventana activa.
Tenga en cuenta que puede establecer un valor predeterminado para todas las vistas
en la página
Comando Barra de desplazamiento horizontal
Muestra u oculta
Comando Selector de fichas
Muestra u oculta las fichas para cambiar entre documentos.
Comando Pantalla completa
Cambia el tamaño de la vista actual para que ocupe toda la pantalla.
Comando Barra de herramientas Estándar
Muestra u oculta la barra de herramientas estándar.
Comando Barra de herramientas Archivo
Muestra u oculta la barra de herramientas que contiene los comandos del menú
Archivo.
Comando Barra de herramientas Edición
Muestra u oculta la barra de herramientas que contiene los comandos del menú
Edición.
La barra de desplazamiento horizontal en la ventana activa. Tenga en cuenta
que puede establecer un valor predeterminado para todas las vistas en la página .
Comando Números de línea
Muestra u oculta los números de línea en la vista activa. Tenga en cuenta que
puede establecer un valor predeterminado para todas las vistas en la página
Comando Espacios visibles
Muestra los espacios, tabuladores y marcas de párrafo como caracteres visibles
en la vista activa. Si no hay documentos abiertos, es el valor predeterminado para
todas las vistas. Tenga en cuenta que puede controlar cuáles caracteres desea que
estén visibles en la página.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
22
Comando En el explorador Web
Muestra el documento activo en el explorador de web predeterminado. Este
comando sólo está disponible para documentos HTML. También aparece en el
menú contextual de los documentos HTML.
Para que funcione, el explorador debe haberse asociado a la extensión del
nombre de archivo del documento.
Comando Propiedades del documento
Muestra las propiedades del documento activo
MENU HERRAMIENTAS:
Comando Comparar archivos
Utilice este comando para buscar diferencias entre dos archivos de texto.
Aparecerá el cuadro de diálogo Comparar archivos de texto, en el que puede
especificar los nombres de los archivos.
Comando Ortografía
Utilice este comando para comprobar la ortografía del documento activo.
Comando Ordenar
Utilice este comando para ordenar las líneas seleccionadas.
Comando Convertir
Utilice este comando para cambiar el conjunto de caracteres del documento
activo entre ANSI y DOS (también denominado OEM o IBM).
Tenga en cuenta que la conversión de caracteres que son únicos para el
conjunto actual de caracteres (como los de dibujo de líneas) no es reversible y que
el comando no se puede deshacer.
Después de convertir a DOS, TextPad selecciona la fuente MS LineDraw y,
después de convertir a ANSI, la fuente predeterminada.
Comando Explorador/Administrador de archivos
Utilice este comando para iniciar el Administrador de archivos de Windows o
el Explorador.
Comando Ejecutar
Utilice este comando para iniciar otra aplicación y, opcionalmente, para
redirigir su salida a la ventana Resultado del comando. Aparecerá el cuadro de
diálogo Ejecutar para que pueda rellenar los detalles.
Comando Herramienta de usuario
Utilice este comando para iniciar una aplicación agregada al menú
Herramientas.
MENU MACROS:
Comando Grabar (menú Macros)
Utilice este comando para iniciar y detener la grabación de una macro.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
23
MENU CONFIGURAR:
Comando Modo de selección de bloque
Utilice este comando para alternar entre los modos de selección de bloques
(columna) y normal. Cuando el modo de selección de bloque está activado, aparece
una marca de verificación delante de este elemento de menú. El estado actual
también aparece en la barra de estado.
Este comando no está disponible en el modo de ajuste de línea.
Comando Ajuste de línea
Utilice este comando para activar y desactivar el modo de ajuste de línea.
Comando Sincronizar desplazamiento
Utilice este comando para activar y desactivar el modo de desplazamiento
sincronizado. Cuando está activado, en la barra de estado aparece "Sínc" y, al
desplazar una vista, todas las vistas de los demás documentos se desplazan
proporcionalmente.
MENU VENTANA
Comando Dividir ventana
Utilice este comando para dividir la ventana activa en 2 ó 4 paneles. A
continuación, puede utilizar el ratón o las teclas de flecha para mover la barra
divisora. Cuando haya terminado, pulse el botón izquierdo o Intro para fijar la
nueva posición de la barra divisora.
Comando Mosaico horizontal
Utilice este comando para organizar las ventanas una sobre otra, sin que se
solapen, de arriba a abajo de la pantalla
Comando Mosaico vertical
Utilice este comando para organizar las ventanas colocadas de lado a lado de la
pantalla.
Comando Cascada
Utilice este comando para organizar las ventanas de forma que se solapen unas
con otras, desde la parte superior izquierda a la parte inferior derecha de la
pantalla.
Comando Organizar iconos
Utilice este comando para organizar los iconos de las ventanas minimizadas en
la parte inferior de la ventana principal. Si hay una ventana de documento abierta
en la parte inferior de la ventana principal, alguno o todos los iconos pueden no
verse, ya que estarían debajo de dicha ventana.
MENU AYUDA:
Comando Temas de ayuda
Utilice este comando para acceder a la pantalla de apertura de la ayuda. Desde
la pantalla de apertura podrá acceder a instrucciones paso a paso y a varios tipos de
información de referencia.Una vez abierta la ayuda, haga clic en el botón
Contenido cuando desee volver a la pantalla de apertura.
MILDRED MAGDALENA VARGAS HERNANDEZ
FUNDAMENTOS DE PROGRAMACION
PRACTICA 1
24
Comando Consultas frecuentes
Utilice este comando para ver Consultas frecuentes.
Comando TextPad en la Web
Utilice este comando para conectar con la página principal de TextPad a través
del explorador de web predeterminado. En caso de que este comando no pueda
conectar automáticamente, la URL es http://www.textpad.com/.
Comando Sugerencia del día
Utilice este comando para mostrar el cuadro de diálogo Sugerencia del día.
Comando Acerca de TextPad
Utilice este comando para mostrar el cuadro de diálogo Acerca de TextPad.
Contiene diversos detalles de la licencia e información sobre los recursos del
sistema.
MILDRED MAGDALENA VARGAS HERNANDEZ